10 Dosa Besar dalam konfigurasi Mikrotik

10 Dosa Besar dalam konfigurasi Mikrotik




Salah satu Dosa yang sering terjadi adalah menambahkan IP Address yang sama pada beberapa Inferface..... 

Download 

 https://goo.gl/ANvJGy
Belajar Mikrotik: Review CWDM-MUX8A

Belajar Mikrotik: Review CWDM-MUX8A

Review CWDM-MUX8A



WDM (wavelength-Division Multiplexing) merupakan sebuah teknologi dalam jaringan fiber optic yang bisa digunakan untuk menggabungkan beberapa sinyal optic ke dalam sebuah kabel fiber optic fisik menggunakan beberapa wavelength yang berbeda. WDM memungkinkan komunikasi 2 arah untuk beberapa sinyal tranmisi dengan hanya melewati 1 kabel fiber optic fisik. Teknologi ini menjadi solusi atas terbatasnya kabel fiber optic fisik yang bisa digunakan dibanding dengan banyaknya tranmisi yang dibutuhkan. 
WDM system bisa dibangun dengan menggunakan sepasang alat bernama Multiplexer dan Demultiplexer. Multiplexer dipasang sebagai transmitter untuk menggabungkan beberapa sinyal optic. Multiplexer dihubungkan ke sebuah Demultiplexer dengan satu fiber optic. Demultiplexer berfungsi untuk kembali memecah sinyal optic dari satu kabel ke banyak kabel fiber optic fisik. 
Teknologi WDM dibagi ke dalam 2 jenis, yakni DWDM (dense wavelength division multiplexing) dan CWDM (coarse wavelength division multiplexing). Secara fungsi keduanya memiliki fungsi yang sama, hanya saja berbeda pada sisi jarak wavelength, jumlah channel yang dapat dihandle dan kemampuan memperkuat sinyal optic terutama pada koneksi jarak jauh. Secara sederhana, DWDM biasa digunakan untuk skala jaringan yang besar, sedangkan CWDM untuk jaringan skala menengah dengan jarak antar site lebih pendek. 
Di Mikrotik sendiri, dalam hal teknologi fiber optic, beberapa produk router dan switch Mikrotik sudah disediakan SFP Cage, sehingga produk-produk Mikrotik sudah dapat digunakan pada jaringan fiber optic. Sebut saja produk seri CloudCoreRouter (CCR) , switch CRS dan beberapa produk Router Indoor untuk SOHO semacam hAP Ac, RB2011 dan sebagainya. 
Untuk menambah lini produk perangkat jaringan fiber optic, baru-baru ini Mikrotik merilis produk CWDM-MUX8A (Coarse Wavelength-Division Multiplexing) 8 channel. CWDM-MUX8A merupakan perangkat Multiplexser (MUX) dan bisa juga difungsikan sebagai Demultiplexser (DEMUX) pasif. 
  
CWDM-MUX8A ini memungkinkan kita untuk membangun hingga 8 channel. Setiap channel pada CWDM-MUX8A memiliki wave length atau panjang gelombang yang berbeda-beda. Panjang gelombang yang disediakan adalah 1470, 1490, 1510, 1530, 1550, 1570, 1590, 1610. Produk CWDM-MUX8A ini bisa digunakan untuk SFP 1G, SFP+ (SFP 10G), bisa juga digunakan secara bersamaan. Untuk SFP-1G dapat mencapai jarak hingga 40km sedangkan SFP-10G up to 10km. 
Pada sebelah kiri terdapat 2 port, yakni port Line dan Monitor. Port Line digunakan sebagai jalur backbone fiber optic untuk menghubungkan MUX ke DEMUX. Port Monitor digunakan untuk melakukan monitoring power dari Fiber Optic menggunakan perangkat OPM (Optical Power Meter). 

Sebagai gambaran penggunaan, CWDM-MUX8A dapat diimplementasikan untuk menghubungkan dua daerah yang sebenarnya membutuhkan lebih dari 1 koneksi fiber optic seperti gambar berikut ; 

 
Contoh Kasus :
Sebagai contoh kasus, terdapat sebuah penyedia layanan yang melayani banyak client di area dengan jarak 40km dari kantor pusat. Setiap client mendapat akses dan layanan dengan kebijakan yang berbeda menggunakan kabel fiber optic. Jika dari kantor penyedia layanan ke client dihubungkan dengan sebuah kabel fiber optic, maka perusahaan penyedia layanan tersebut harus membangun koneksi fiber optic  sejumlah client yang terkoneksi. 
Tanpa CWDM 

Skema ini selain membutuhkan waktu yang cukup lama untuk membangun infrastruktur fiber optic tentu saja membutuhkan biaya yang tidak sedikit. Belum lagi jika jumlah client terus bertambah, berarti harus kembali menarik kabel baru.
Dengan CWDM
Pada kondisi tersebutlah kita dapat mengimplementasikan CWDM-MUX8A. Sehingga dari kantor penyedia ke client cukup dibangun satu kabel fiber optic saja. Perangkat CWDM-MUX8A akan melewatkan semua sinyal / channel fiber optic tersebut hanya melalui satu kabel fiber optic saja. Cukup gunakan sepasang CWDM-MUX8A pada kedua titik seperti gambar berikut : 
 
Dengan kondisi tersebut, misal di sisi cabang / client penggunanya bertambah, maka tidak perlu menarik kabel fiber optic yang baru, sebab CWDM-MUX8A menyediakan hingga 8 port / channel SFP yang bisa digunakan. 

Keuntungan penggunaan CWDM-MUX8A: 
  1. Meningkatkan efisiensi jaringan fiber optik yang ada, Karena hanya menggunakan 1 line kabel fiber optic sebagai backbone untuk menghubungkan beberapa titik.
  2. Mudah digunakan.
  3. CWDM tidak membutuhkan listrik, sehingga kita dapat menghemat konsumsi listrik
  4. Mengurangi pemeliharaan peralatan dan biaya instalasi Fiber Optik tentunya.
  5. Produk ini bisa digunakan dengan produk non Mikrotik yang berada di pasaran. 
Sumber: www.mikrotik.co.id
Belajar Mikrotik: Solusi remote IP Publik Dynamic dengan NOIP.com

Belajar Mikrotik: Solusi remote IP Publik Dynamic dengan NOIP.com

Solusi remote IP Publik Dynamic dengan NOIP.com


Dalam implementasi pengelolaan sebuah jaringan, terkadang kita membutuhkan akses ke sebuah host atau Router dalam jaringan tersebut. Sebagai contoh misalnya pada Router diaktifkan service VPN Server yang diaktifkan agar Client dari public (internet) bisa dial ke Router tersebut. 
Cara paling mudah agar sebuah perangkat bisa diakses dari internet adalah dengan memasang alamat IP Public pada alat tersebut. Kendalanya adalah pada kondisi tertentu IP Public yang terpasang bukan alamat IP static, namun bisa jadi merupakan alamat IP Public Dynamic yang bisa berubah sewaktu-waktu.
Pada kondisi tersebut sangat tidak efektif jika pada sisi VPN Client menunjuk alamat IP Server saat melakukan dial. Sebab jika alamat IP pada sisi server berubah, tentu link VPN akan down. Sebagai alternatif, kita bisa mendaftarkan alamat IP Public kita untuk bisa diubah menjadi nama domain, sehingga dari sisi Client bisa menunjuk nama domain tersebut saat melakukan dial VPN. Tidak hanya VPN, namun misal remote Winbox dan yang lain bisa juga menggunakan nama domain tersebut. 
Remote RouterBoard Mikrotik yang memiliki IP Public Dynamic saat ini sudah tidak menjadi masalah sebab mulai Router OS versi 6.14 sudah tersedia fitur yang bernama IP Cloud. Dengan fitur ini, kita bisa mendapatkan nama domain untuk ip public kita, sehingga Mikrotik bisa diakses menggunakan alamat nama domain tersebut. Ketika IP Public berubah maka router akan melakukan update ke Mikrotik.com sehingga router tetap bisa diakses dengan nama domain yang sama. 
IP Cloud ini bisa didapatkan secara gratis, hanya perlu mengaktifkan fungsinya saja dalam pengaturan RouterBoard. Format nama domain yang akan didapatkan adalah [SNRouterBoard].sn.mynetname.net. Cukup panjang memang dan mungkin tidak mudah diingat. Mengenai IP Cloud dapat Anda baca lebih dalam lagi pada artikel kami yang berjudul Solusi Dynamic IP Public dengan IP Cloud.
Selain IP Cloud yang disediakan mikrotik, kita juga bisa menggunakan layanan pihak ketiga, misalnya seperti www.noip.com . Konfigurasi menggunakan layanan pihak ketiga memang tidak semudah ketika menggunakan IP Cloud. Kita harus melakukan pendaftaran akun dan membuat script update agar ketika alamat IP Public berubah, Router dapat meng-update ke server penyedia. 
Langkah awal untuk menggunakan layanan noip.com adalah melakukan pendaftaran akun. Pada langkah ini selain menentukan username akun. Setelah pendaftaran akun kita bisa menentukan nama hostname pilihan kita serta menginputkan alamat IP Public router kita yang aktif saat ini. Noip.com menyediakan banyak domain yang bisa kita pilih. 
Jika langkah ini sudah selesai maka Router Mikrotik sudah bisa kita akses menggunakan alamat hostname tersebut. Misal ketika remote menggunakan winbox, pada kolom "Connect To" bisa kita isikan nama hostname tersebut.
 

 
Karena menggunakan layanan pihak ketiga yang tidak memiliki fitur update otomatis ketika IP Router berubah, maka pada Router harus ditambahkan mekanisme untuk menginformasikan alamat ip yang aktif ke server noip.com . Untuk kebutuhan ini kita harus menambahkan sebuah script seperti berikut : 
  
Script update Dynamic DNS untuk NOIP.com 
 # No-IP automatic Dynamic DNS update 

#--------------- Change Values in this section to match your setup ------------------ 

# No-IP User account info 
:local noipuser "testmikrotik
:local noippass "testes123

# Set the hostname or label of network to be updated. 
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names. 
# To specify multiple hosts, separate them with commas. 
:local noiphost "testmikrotik.ddns.net

# Change to the name of interface that gets the dynamic IP address 
:local inetinterface "ether 1

#------------------------------------------------------------------------------------ 
# No more changes need 

:global previousIP 

:if ([/interface get $inetinterface value-name=running]) do={ 
# Get the current IP on the interface 
   :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address] 

# Strip the net mask off the IP address 
   :for i from=( [:len $currentIP] - 1) to=0 do={ 
       :if ( [:pick $currentIP $i] = "/") do={ 
           :set currentIP [:pick $currentIP 0 $i] 
       } 
   } 

   :if ($currentIP != $previousIP) do={ 
       :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed" 
       :set previousIP $currentIP 

# The update URL. Note the "3F" is hex for question mark (?). Required since ? is a special character in commands. 
       :local url "http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP" 
       :local noiphostarray 
       :set noiphostarray [:toarray $noiphost] 
       :foreach host in=$noiphostarray do={ 
           :log info "No-IP: Sending update for $host" 
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt") 
           :log info "No-IP: Host $host updated on No-IP with IP $currentIP" 
       } 
   }  else={ 
       :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed" 
   } 
} else={ 
   :log info "No-IP: $inetinterface is not currently running, so therefore will not update." 


Ada beberapa parameter yang harus Anda perhatikan, yaitu: 
  1. :local noipuser "testmikrotik" (Username untuk login di NOIP.com).
  2. :local noippass "testes123" (Password yang digunakan untuk login di NOIP.com).
  3. :local noiphost "testmikrotik.ddns.net" (Hostname yang dibuat pada NOIP.com).
  4. :local inetinterface "ether 1" (Interface Router yang mengarah ke internet).
Script tersebut bisa dijalankan dengan interval waktu tertentu dengan menggunakan scheduler. Misal Router kita set agar melakukan update setiap 15 menit. Tentu interval ini bisa dicustom sesuai kebutuhan.

  

Script update ini sangat dibutuhkan agar saat IP Public yang terpasang di Router berubah kita tetap bisa melakukan remote mikrotik menggunakan Domain dari NOIP.com . Layanan noip.com sebenarnya merupakan layanan berbayar namun kita diberikan waktu trial selama 30 hari. Untuk berlangganan Domain dari NOIP.com selama 1 tahun dikenakan biaya sebesar $24.95 up to 25 hostname pada saat artikel ini dibuat. 

Belajar Mikrotik: Vlan pada Wireless Virtual (VAP)

Belajar Mikrotik: Vlan pada Wireless Virtual (VAP)

Vlan pada Wireless Virtual (VAP)


Multiple SSID adalah salah satu fitur yang sering digunakan dalam distribusi akses jaringan melalui media nirkabel/wireless. Dengan menggunakan metode ini, ketika kita hanya memiliki satu interface fisik wireless pada router maka kita dapat memancarkaan lebih dari 1 SSID dengan service yang berbeda-beda. 
Fitur Virtual Akses Point (VAP) kerap diimplementasikan pada jaringan kantor, kampus, dsb guna memenuhi kebutuhan akses wireless yang berbeda. Sebagai contoh kasus, pada jaringan kantor akan dibuat 2 SSID yang berbeda pada satu interface wireless fisik. Untuk membuat Multiple SSID dengan Virtual Akses Point (VAP) di Mikrotik dapat Anda lihat pada artikel kami yang berjudul Multiple SSID dengan VAP di Mikrotik.
Kemudian timbul sebuah pertanyaan, Apakah Vlan bisa diterapkan pada interface Wireless atau interface Wireless-Virtual (VAP) Mikrotik? Jawabannya adalah BISA, dan berikut topologi yang kami gunakan
  
Router-1 di interface ether5 terdapat 2 Vlan-id, yaitu vlan-id=10vlan-id=20. Kemudian ether5 pada Router-1terhubung ke ether1 pada Router-2Laptop dan Handphone yang akan mengakses vlan-id=10vlan-id=20terhubung ke interface Wlan1, dan Wlan2 (VAP) pada Router-2.
Konfigurasi Router-1
  
Pada Router-1, kita harus mendefinisikan Vlan-id=10 dan Vlan-id=20 di interface ether5. Kemudian kita berikan IP pada masing-masing interface Vlan tersebut.
 
Kita juga berikan servis DHCP Server pada tiap interface Vlan.
 
Konfigurasi Router-2 
Langkah pertama Anda harus konfigurasi Wireless pada Router-2 dikarenakan interface Wireless pada Router-2nanti yang dijadikan sebagai Access Portnya. 
 
Setelah selesai melakukan konfigurasi pada interface wlan1, maka selanjutnya adalah membuat interface wlan - Virtual (VAP), Caranya pilih pada menu Wireless -> klik Add [+] -> Virtual. Dan contoh konfigurasinya adalah sebagai berikut:
 
Setelah langkah-langkah diatas kita lakukan maka pada tab interface akan muncul dua interface wlan seperti gambar berikut: 
Konfigurasi berikutnya adalah membuat interface bridge1
 /interface bridge add name=bridge1 vlan-filtering=no
Port yang akan di bridge di dalam interface bridge1 adalah interface yang berasal dari Router-1 (tagged = ether1) dan interface yang akan ke end device (Untagged = wlan1 dan wlan2). Kemudian tambahkan PVID Vlan, dengan cara masuk ke tab ''VLAN'' kemudian tentukan PVID sesuai dengan kebutuhan, wlan1 (PVID=10) sedangkan wlan2 (PVID=20)
 /interface bridge port 
  add bridge=bridge1 interface=ether1 
  add bridge=bridge1 interface=wlan1 pvid=10 
  add bridge=bridge1 interface=wlan2 pvid=20 

 
Setelah berhasil menambahkan interface kedalam bridge dan juga sudah menentukan VLAN PVID, maka langkah selanjutnya adalah menambahkan bridge VLAN, dan tentukan Tagged dan Untagged port di dalamnya.
 /interface bridge vlan 
  add bridge=bridge1 tagged=ether1 untagged=wlan1 vlan-ids=10 
  add bridge=bridge1 tagged=ether1 untagged=wlan2 vlan-ids=20

 
Setelah semua vlan terkonfigurasi dengan benar, kemudian enable vlan filteringnya
 /interface bridge set bridge1 vlan-filtering=yes

 
Tahap Pengujian 
Untuk Tahap Pengujian, pada Laptop dan Handphone kita aktifkan DHCP Client. Kemudian dipastikan untuk IP yang didapat adalah IP Vlan10 dan IP Vlan20. Anda dapat lakukan pengecekan dengan cara Masuk ke Router-1, kemudian IP>>DHCP Server>>Lease
  
Fitur Virtual Akses Point (VAP) pada Mikrotik juga bisa digunakan sebagai wireless repeater,  Untuk detailnya dapat anda lihat pada artikel kami yang berjudul Wireless Repeater, Fitur Baru di MikroTik.

Sumber: www.mikrotik.co.id
Belajar Mikrotik: Login Hotspot Menggunakan MAC-Address

Belajar Mikrotik: Login Hotspot Menggunakan MAC-Address

Login Hotspot Menggunakan MAC-Address


Hotspot merupakan fitur MikroTik yang paling banyak digunakan untuk mengelola koneksi jaringan terutama koneksi wireless di public area. Dan fitur ini juga merupakan salah satu keunggulan dan banyak orang yang menggunakan MikroTik karena adanya fitur hotspot ini. Beragam konfigurasi yang bisa disetting pada fitur ini sehingga banyak meng-cover kebutuhan jaringan yang diinginkan.
Pada artikel kali ini akan dibahas salah satu konfigurasi yang bisa diterapkan pada hotspot MikroTik, yaitu login hotspot berdasarkan MAC Address perangkat client. Metode ini hampir sama dengan 'IP Binding', ketika client terkoneksi ke jaringan hotpsot tidak perlu lagi memasukkan username dan password untuk authentikasi. Namun dengan cara ini kita masih bisa management client melalui 'Hotspot User Profile' dan juga beberapa parameter pada 'Hotspot User'.
Langkah pertama yang harus dikonfigurasi adalah pada 'Server Profile' yang digunakan. Kemudian pilih pada Tab 'Login'.
Kita pilih opsi 'MAC' pada parameter 'Login by'. Dengan memilih opsi tersebut kita akan mengaktifkan parameter MAC Auth ModeDan kita pilih 'MAC as Username and Password'.
Selanjutnya, kita akan konfigurasi pada menu 'User' untuk membuat account sebagai authentikasi hotspot. Berdasarkan konfigurasi diatas kita bisa menggunakan MAC Address dari perangkat client sebagai username dan password.
Sampai langkah ini harusnya ketika ada client yang terkoneksi ke jaringan hotspot dengan perangkat yang MAC Address-nya sudah masuk dalam pengaturan di menu user, maka secara otomatis akan langsung ter-authentikasi tanpa harus memasukkan username dan password lagi. 
Selain itu, kita juga masih tetap bisa melakukan management melalui menu 'Hotspot User Profile' seperti pengaturan bandwidth secara dinamis, packet/connection marking, session/keepalive timeout, dll.
 

Sumber: www.mikrotik.co.id